BlueSpice MediaWiki REL1_27
 All Classes Namespaces Files Functions Variables Groups Pages
Maps installation

These are the installation and configuration instructions for the Maps extension.

Versions

Status Release date Git branch
Maps 3.8.x Stable release 2016-08-24 3.8.0
Maps 3.7.x Stable release 2016-06-21 3.7.0
Maps 3.6.x Obsolete release 2016-05-26 3.6.0
Maps 3.5.x Obsolete release 2016-04-01 3.5.0
Maps 3.4.1 Obsolete release 2016-01-30 3.4.1
Maps 3.4 Obsolete release 2015-07-25 3.4.0
Maps 3.3 Obsolete release 2015-06-29 3.3.0
Maps 3.2 Obsolete release 2014-09-12 3.2.0
Maps 3.1 Obsolete release 2014-06-30 3.1.0
Maps 3.0.1 Obsolete release 2014-03-27 3.0.1
Maps 2.0.x Obsolete release 2012-12-13 2.0.x
Maps 1.0.5 Obsolete release 2011-11-30 1.0.5

Platform compatibility

The PHP and MediaWiki version ranges listed are those in which Maps is known to work. It might also work with more recent versions of PHP and MediaWiki, though this is not guaranteed. Increases of minimum requirements are indicated in bold.

PHP MediaWiki Composer Validator
Maps 3.8.x 5.5 - 7.0 1.23 - 1.28 Required 2.x (handled by Composer)
Maps 3.7.x 5.5 - 7.0 1.23 - 1.28 Required 2.x (handled by Composer)
Maps 3.6.x 5.5 - 7.0 1.23 - 1.27 Required 2.x (handled by Composer)
Maps 3.5.x 5.3.2 - 7.0 1.18 - 1.27 Required 2.x (handled by Composer)
Maps 3.4.x 5.3.2 - 7.0 1.18 - 1.27 Required 2.x (handled by Composer)
Maps 3.3.x 5.3.2 - 5.6.x 1.18 - 1.25 Required 2.x (handled by Composer)
Maps 3.1.x & 3.2.x 5.3.2 - 5.6.x 1.18 - 1.24 Required 2.x (handled by Composer)
Maps 3.0.x 5.3.2 - 5.6.x 1.18 - 1.23 Required 1.x (handled by Composer)
Maps 2.0.x 5.3.2 - 5.5.x 1.18 - 1.23 Not supported 0.5.1
Maps 1.0.5 5.2.0 - 5.3.x 1.17 - 1.19 Not supported 0.4.13 or 0.4.14

When installing Maps 2.x, see the installation instructions that come bundled with it. Also make use of Validator 0.5.x. More recent versions of Validator will not work.

Database support

All current versions of Maps have full support for all databases that can be used with MediaWiki.

Download and installation

Go to the root directory of your MediaWiki installation.

If you have previously installed Composer skip to step 2.

To install Composer, just download http://getcomposer.org/composer.phar into your current directory.

wget http://getcomposer.org/composer.phar

Step 2

Now using Composer, install Maps

php composer.phar require mediawiki/maps "*"

Verify installation success

As final step, you can verify Maps got installed by looking at the Special:Version page on your wiki and verifying the Maps extension is listed.

Configuration

At present, minimal configuration is needed to get Maps running. Configuration is done like in most MediaWiki extensions,by placing some simple snippets of PHP code at the bottom of MediaWiki's LocalSettings.php.

As of June 2016, Google requires you to provide an API key when you where not already using their maps API. This means that you will either need to configure this key, or use another of the supported mapping services.

Required configuration for Google Maps

$GLOBALS['egMapsGMaps3ApiKey'] = 'your-api-key';

Not using Google Maps by default

For OpenLayers:

$GLOBALS['egMapsDefaultService'] = 'openlayers';

For Leaflet:

$GLOBALS['egMapsDefaultService'] = 'leaflet';

You might also want to fully disable Google Maps by placing a copy of the egMapsAvailableServices setting in LocalSettings, and removing the googlemaps3 line.

See the Maps settings file for all available configuration options.